summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-11 12:27:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-11 12:27:01 +0100
commit2fef54fd64495148e0c546ef4ecaacf9503e62db (patch)
tree9ea5d60416f379f23bbc9ef7680db22b2069cd1e /gnu
parentcbb6a15056bd90c3fa9d03a50a347ac148ab64d9 (diff)
downloadguix-2fef54fd64495148e0c546ef4ecaacf9503e62db.tar.gz
gnu: hpcguix-web: Do not re-bootstrap.
* gnu/packages/web.scm (hpcguix-web)[arguments]: Do not run autoreconf after
the bootstrap phase; remove "autoconf" phase to "set-variables"; end phase
with #T.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b0ab4add8d..03deab422d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6761,14 +6761,14 @@ compressed JSON header blocks.
                     (srfi srfi-26)
                     (ice-9 popen)
                     (ice-9 rdelim))
-
          #:phases
          (modify-phases %standard-phases
-           (add-before 'configure 'autoconf
+           (add-before 'configure 'set-variables
              (lambda _
+               ;; This prevents a few warnings
                (setenv "GUILE_AUTO_COMPILE" "0")
                (setenv "XDG_CACHE_HOME" (getcwd))
-               (invoke "autoreconf" "-vif")))
+               #t))
            (add-after 'install 'wrap-program
              (lambda* (#:key inputs outputs #:allow-other-keys)
                (let* ((out      (assoc-ref outputs "out"))