summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-30 20:58:39 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:22 +0300
commit3a952dc04c980df43f9cbf1eacb2fb550e506e38 (patch)
tree149bf22a26ba9007bfaed7b130e779926ca4cc52 /gnu
parentc0dfd0470945b1e2d560aa2efc348283b8be0d39 (diff)
downloadguix-3a952dc04c980df43f9cbf1eacb2fb550e506e38.tar.gz
gnu: Add python-stsynphot.
* gnu/packages/astronomy.scm (python-stsynphot): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d82ff7c91f..af35b75e8f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2122,6 +2122,40 @@ task}.")
 image processing functions: @code{xyxymatch}, @code{geomap}.")
     (license license:bsd-3)))
 
+(define-public python-stsynphot
+  (package
+    (name "python-stsynphot")
+    (version "1.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "stsynphot" version))
+              (sha256
+               (base32
+                "0qkdh47j84v7fzri7bmi1jcmggdqq0a8byamfm73d8mbz86v8sn4"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      ;; XXX: Tests fails on missing file, it might need to be downloaded,
+      ;; disable them for now.  astropy.utils.exceptions.AstropyUserWarning:
+      ;; Failed to load Vega spectrum from
+      ;; /grp/redcat/trds/calspec/alpha_lyr_stis_010.fits;
+      #:tests? #f))
+    (propagated-inputs (list python-astropy
+                             python-beautifulsoup4
+                             python-matplotlib
+                             python-numpy
+                             python-scipy
+                             python-synphot))
+    (native-inputs (list python-pytest python-pytest-astropy
+                         python-pytest-astropy-header python-setuptools-scm))
+    (home-page "https://github.com/spacetelescope/stsynphot_refactor")
+    (synopsis "Synthetic photometry using Astropy for HST and JWST")
+    (description
+     "This package provides a replacement for IRAF STSDAS SYNPHOT and ASTROLIB
+PYSYNPHOT, utilizing Astropy covering instrument specific portions of the old
+packages for HST.")
+    (license license:bsd-3)))
+
 (define-public libnova
   (package
     (name "libnova")