summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-10-10 22:50:26 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-10-10 22:53:50 +0300
commit45cad97d9ee15a4b43e83d735185ff633a95cc09 (patch)
treee808f3a7cd4c8fac4471b5d0fa74495926919b2a /gnu
parente42765b675d5f3fced0720c1a66350c635fd8643 (diff)
downloadguix-45cad97d9ee15a4b43e83d735185ff633a95cc09.tar.gz
gnu: obs: Fix missing icons.
Fixes <https://bugs.gnu.org/43556>.
Reported-by: bdju <bdju@tilde.team>.

* gnu/packages/video.scm
(obs)[arguments]<phases>: Add 'wrap-executable' which fixes missing icons.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b39bd7cada..93508910aa 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3011,7 +3011,16 @@ be used for realtime video capture via Linux-specific APIs.")
     (arguments
      `(#:configure-flags
        (list (string-append "-DOBS_VERSION_OVERRIDE=" ,version)
-             "-DENABLE_UNIT_TESTS=TRUE")))
+             "-DENABLE_UNIT_TESTS=TRUE")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'wrap-executable
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out"))
+                   (plugin-path (getenv "QT_PLUGIN_PATH")))
+               (wrap-program (string-append out "/bin/obs")
+                 `("QT_PLUGIN_PATH" ":" prefix (,plugin-path))))
+             #t)))))
     (native-inputs
      `(("cmocka" ,cmocka)
        ("pkg-config" ,pkg-config)))