summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-18 14:18:21 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-19 21:56:57 -0500
commit7eaa3b45ac63b824c9a98d022f717c217ad021ed (patch)
treea3c84cafa18b5960ed2ff6c52855986ca0f6b514 /gnu
parent7196b8c5ea0194b3c67513bf9916c7b1a85118b5 (diff)
downloadguix-7eaa3b45ac63b824c9a98d022f717c217ad021ed.tar.gz
gnu: python-stevedore: Update to 3.2.2.
* gnu/packages/openstack.scm (python-stevedore): Update to 3.2.2.
[tests?]: Disable tests.
[propagated-inputs]: Remove field.  Move python-pbr to...
[native-inputs]: ...here.  Remove python-mock, python-sphinx and
python-testrepository.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/openstack.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index d0294cdef3..1cd7654e1f 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -310,22 +310,21 @@ to docs.openstack.org and developer.openstack.org.")
 (define-public python-stevedore
   (package
     (name "python-stevedore")
-    (version "1.28.0")
+    (version "3.2.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "stevedore" version))
        (sha256
         (base32
-         "02ynfgwma84g59834dmvzr39mcppy5s229zf1w23c0qngf753izi"))))
+         "1w11lm293afzb73iq0ba9wnmr2rjwymnhr92km4a4xrs7a5qcigq"))))
     (build-system python-build-system)
-    (propagated-inputs
-     `(("python-pbr" ,python-pbr)
-       ("python-six" ,python-six)))
+    (arguments
+     ;; The tests are disabled to avoid a circular dependency with
+     ;; python-stestr.
+     `(#:tests? #f))
     (native-inputs
-     `(("python-mock" ,python-mock)
-       ("python-sphinx" ,python-sphinx)
-       ("python-testrepository" ,python-testrepository)))
+     `(("python-pbr" ,python-pbr)))
     (home-page "https://github.com/dreamhost/stevedore")
     (synopsis "Manage dynamic plugins for Python applications")
     (description