summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-27 21:16:22 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:54:02 -0500
commit8454438e0532aa026534510a0f6677552fc0e810 (patch)
tree0a8ab53fe2885b25a31e8e582b07566da92ce096 /gnu
parent6275b9bc2e6b2aeac513e8bd3414aa999cb44471 (diff)
downloadguix-8454438e0532aa026534510a0f6677552fc0e810.tar.gz
gnu: freecad: Wrap with GUIX_PYTHONPATH.
* gnu/packages/engineering.scm (freecad)
[phases]{restore-pythonpath}: Delete phase.
{wrap-pythonpath}: Replace PYTHONPATH with GUIX_PYTHONPATH.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/engineering.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index c9e90c4f5b..bcc6ddb284 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2591,18 +2591,12 @@ full programmatic control over your models.")
                          "/include/shiboken2"))
          #:phases
          (modify-phases %standard-phases
-           (add-before 'configure 'restore-pythonpath
-             (lambda _
-               (substitute* "src/Main/MainGui.cpp"
-                 (("_?putenv\\(\"PYTHONPATH=\"\\);") ""))
-               #t))
            (add-after 'install 'wrap-pythonpath
              (lambda* (#:key outputs #:allow-other-keys)
                (let ((out (assoc-ref outputs "out")))
                  (wrap-program (string-append out "/bin/FreeCAD")
-                   (list "PYTHONPATH"
-                         'prefix (list (getenv "GUIX_PYTHONPATH")))))
-               #t)))))
+                   (list "GUIX_PYTHONPATH"
+                         'prefix (list (getenv "GUIX_PYTHONPATH"))))))))))
       (home-page "https://www.freecadweb.org/")
       (synopsis "Your Own 3D Parametric Modeler")
       (description