summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-01-01 12:58:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-01-01 13:33:03 +0100
commit9380968a8fd0ef5445f5d9e4de12b5e054fa559d (patch)
tree5306edee2573aa636450fbd7aababa843324dab0 /gnu
parent536a7ca2aaf7cf7bd386cca3d6ce4fa2eb43a025 (diff)
downloadguix-9380968a8fd0ef5445f5d9e4de12b5e054fa559d.tar.gz
gnu: Add r-adaptalint.
* gnu/packages/cran.scm (r-adaptalint): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6b88203859..b263b6a425 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19206,3 +19206,29 @@ these four functions: @code{rARS()}, @code{rMARS()}, @code{rCCARS()}, and
 @code{rASS()}.  These functions can realize sampling based on the algorithms
 above.")
     (license license:gpl2)))
+
+(define-public r-adaptalint
+  (package
+    (name "r-adaptalint")
+    (version "0.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "adaptalint" version))
+       (sha256
+        (base32
+         "15qdcvnnbgcps8j5k79354wsc9alswijv8lcafg2i3lghaw536yf"))))
+    (properties `((upstream-name . "adaptalint")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-dplyr" ,r-dplyr)
+       ("r-lintr" ,r-lintr)
+       ("r-purrr" ,r-purrr)))
+    (home-page "https://cran.r-project.org/web/packages/adaptalint/")
+    (synopsis "Check R code style")
+    (description
+     "This package provides tools to infer the code style (which style rules
+are followed and which ones are not) from one package and use it to check
+another.  This makes it easier to find and correct the most important problems
+first.")
+    (license license:gpl3)))