summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-03-30 15:05:31 +0200
committerLeo Famulari <leo@famulari.name>2016-04-06 17:38:42 -0400
commit9e3ba31c53756d8b91113574e2f340bfdc187827 (patch)
treeefb066e3bc7acf6a983f8f4da16f78c2ad9729cf /gnu
parentb669d9c4c8ee4158f6122e29d807e0f9b2cd73c5 (diff)
downloadguix-9e3ba31c53756d8b91113574e2f340bfdc187827.tar.gz
gnu: Add r-zlibbioc.
* gnu/packages/bioinformatics.scm (r-zlibbioc): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a2cd29b3e7..500a08b283 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4773,6 +4773,25 @@ identify genotyping errors, and to perform single-QTL and two-QTL,
 two-dimensional genome scans.")
   (license license:gpl3)))
 
+(define-public r-zlibbioc
+  (package
+    (name "r-zlibbioc")
+    (version "1.16.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "zlibbioc" version))
+              (sha256
+               (base32
+                "01wc26ndg4jsn1wyrl6zzq636gxaip5fci0xapym4lh9wryc4wnw"))))
+    (properties
+     `((upstream-name . "zlibbioc")))
+    (build-system r-build-system)
+    (home-page "https://bioconductor.org/packages/zlibbioc")
+    (synopsis "Provider for zlib-1.2.5 to R packages")
+    (description "This package uses the source code of zlib-1.2.5 to create
+libraries for systems that do not have these available via other means.")
+    (license license:artistic2.0)))
+
 (define-public pepr
   (package
     (name "pepr")