summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-12-15 20:37:02 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-12-15 20:37:02 +0100
commitb574ccc45371eb5c1df3089be783fedb39273e33 (patch)
tree772396bc6ba47396a8e291a1f98c55fba3a074f0 /gnu
parent88ad26487165b4829089e44beeeb0aa125bf185b (diff)
downloadguix-b574ccc45371eb5c1df3089be783fedb39273e33.tar.gz
gnu: polari: Use polari command to launch Polari.
The rationale for patching the Exec line is similar to what is done for
gnome-weather.

* gnu/packages/gnome.scm (polari)[#:phases]: Add ‘fix-desktop-file’ phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ad49f6ed25..9248475eb8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11564,6 +11564,13 @@ environment.")
              (substitute* "meson/meson-postinstall.sh"
                (("gtk-update-icon-cache") (which "true")))
              #t))
+         (add-after 'install 'fix-desktop-file
+           ;; Hardcode launcher to be on the safe side
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (substitute* (string-append out "/share/applications/"
+                                           "org.gnome.Polari.desktop")
+                 (("Exec=.*") "Exec=" out "/bin/polari")))))
          (add-after 'glib-or-gtk-wrap 'wrap-typelib
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((prog (string-append (assoc-ref outputs "out")