summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-19 00:29:14 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-27 00:06:06 +0100
commitbe541810ec1a98670c990b97038e1e3bb74299d9 (patch)
tree8a9e70e977b028dab6ec3efb69b3536df8b96967 /gnu
parent37ad6d1c7c4bfbf7f2a1a99923ead838f9ab8846 (diff)
downloadguix-be541810ec1a98670c990b97038e1e3bb74299d9.tar.gz
gnu: Remove python2-celery.
* gnu/packages/python-xyz.scm (python2-celery): Remove variable.
(python-celery)[properties]: Remove.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bd13efec51..d06dca68ea 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14132,16 +14132,7 @@ supports scheduling as well.  The execution units, called tasks, are executed
 concurrently on a single or more worker servers using multiprocessing,
 Eventlet, or gevent.  Tasks can execute asynchronously (in the background) or
 synchronously (wait until ready).")
-    (license license:bsd-3)
-    (properties `((python2-variant . ,(delay python2-celery))))))
-
-(define-public python2-celery
-  (let ((celery (package-with-python2
-                 (strip-python2-variant python-celery))))
-    (package/inherit celery
-      (native-inputs `(("python2-unittest2" ,python2-unittest2)
-                       ("python2-mock" ,python2-mock)
-                       ,@(package-native-inputs celery))))))
+    (license license:bsd-3)))
 
 (define-public python-translitcodec
   (package