summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-28 19:33:35 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-30 00:00:58 +0100
commitc1c36f135133794a4d08298bcd20907c4e04bd2b (patch)
treee9ec2be768c84e8d87aeb6599f12477f604c9ed9 /gnu
parent9e6b0775f42c295d559ce676370fcf06287b87a7 (diff)
downloadguix-c1c36f135133794a4d08298bcd20907c4e04bd2b.tar.gz
gnu: python-hy: Honor #:tests? flag.
* gnu/packages/python-xyz.scm (python-hy)[arguments]: Adjust custom 'check
phase to honor the #:tests? flag.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9b651d2108..316549ecf1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13022,12 +13022,13 @@ with a new public API, and RPython support.")
      '(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             (invoke "python" "-m" "pytest" "-k"
-                     (string-append     ; skip some failed tests
-                      "not test_bin_hy_sys_executable"
-                      " and not test_bin_hy_circular_macro_require"
-                      " and not test_macro_from_module")))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "python" "-m" "pytest" "-k"
+                       (string-append   ; skip some failed tests
+                        "not test_bin_hy_sys_executable"
+                        " and not test_bin_hy_circular_macro_require"
+                        " and not test_macro_from_module"))))))))
     (native-inputs
      (list python-pytest))
     (propagated-inputs