summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-10-14 16:45:17 +0200
committerLudovic Courtès <ludo@gnu.org>2021-10-14 16:45:17 +0200
commitc3c502896b1454b345ee9f17d20063853652a35a (patch)
treebc78fc3262dee2a864f120d2bc2bf4c60826885c /gnu
parent5b81999c899e8dc1318b93a4dc62f6bab7382169 (diff)
downloadguix-c3c502896b1454b345ee9f17d20063853652a35a.tar.gz
gnu: Fix Texinfo markup in descriptions of Haskell packages.
* gnu/packages/haskell-xyz.scm (ghc-citeproc)
(ghc-hsyaml-aeson, ghc-lukko): Fix Texinfo markup in descriptions.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 95b3b2ba2b..aa7e3153da 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15854,7 +15854,7 @@ provided.")
     (description
      "@code{ghc-citeproc} parses @acronym{Citation Style Language, CSL} style files
 and uses them to generate a list of formatted citations and bibliography
-entries.  For more information about CSL, see @urefhttps://citationstyles.org/}.")
+entries.  For more information about CSL, see @uref{https://citationstyles.org/}.")
     (license license:bsd-2)))
 
 (define-public ghc-commonmark
@@ -16579,12 +16579,12 @@ using the @code{ghc-postgresql-simple} package.")
      "The @uref{https://yaml.org/spec/1.2/spec.html, YAML 1.2} format provides
 a much richer data-model and feature-set than the
 @uref{https://tools.ietf.org/html/rfc7159, @acronym{JavaScript Object
-Notation, JSON} format.  However, sometimes it's desirable to ignore the extra
+Notation, JSON}} format.  However, sometimes it's desirable to ignore the extra
 capabilities and treat YAML as if it was merely a more convenient markup
 format for humans to write JSON data.  To this end this module provides a
 compatibility layer atop @code{ghc-hsyaml} ,which allows decoding YAML
 documents in the more limited JSON data-model while also providing convenience
-by reusing @code{ghc-aeson}'s @code{FromJSON instances for decoding the YAML
+by reusing @code{ghc-aeson}'s @code{FromJSON} instances for decoding the YAML
 data into native Haskell data types.")
     (license license:gpl2+)))
 
@@ -16619,7 +16619,7 @@ data into native Haskell data types.")
 are alternative file locking packages:
 
 @itemize
-@item @code{GHC.IO.Handle.Lock} in @codebase >= 4.10} is good enough for most
+@item @code{GHC.IO.Handle.Lock} in @code{base >= 4.10} is good enough for most
 use cases.  However, uses only @code{Handle}s so these locks cannot be used
 for intra-process locking.