summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2022-10-26 10:59:05 +0200
committerAndrew Tropin <andrew@trop.in>2022-11-28 14:02:12 +0400
commitd32ed485e10e065529465b23f26591b6b9124c28 (patch)
treede9f96fe051f662f5b5e37808d8c00e21be9a691 /gnu
parent8bbc4dc2fb327b74c3a616234b7fcb198f3583e1 (diff)
downloadguix-d32ed485e10e065529465b23f26591b6b9124c28.tar.gz
gnu: Add rust-clap-lex-0.2.
* gnu/packages/crates-io.scm (rust-clap-lex-0.2): New variable.

Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8a6e8b10c6..2da61b385e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -68473,6 +68473,28 @@ character.")
       "This package provides a library to unify commandline arguments with config files and environment variables.  And make it easier for users to tell your program how to behave across the three main input sources")
     (license license:expat)))
 
+(define-public rust-clap-lex-0.2
+  (package
+    (name "rust-clap-lex")
+    (version "0.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "clap_lex" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1ib1a9v55ybnaws11l63az0jgz5xiy24jkdgsmyl7grcm3sz4l18"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-os-str-bytes" ,rust-os-str-bytes-6))))
+    (home-page "https://github.com/clap-rs/clap/tree/master/clap_lex")
+    (synopsis "Command-line parser for Rust")
+    (description "This package provides a command-line parser for Rust.  As
+opposed to a declarative parser, @code{rust-clap-lex} processes arguments as a
+stream of tokens.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public svd2rust
   (package
     (name "svd2rust")