summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-28 20:20:28 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-28 20:20:28 +0100
commitf90d6c3f69d51f10a47e78c6d57d8e59a7da337e (patch)
treefaf60bc2f944ae4d506f55c4fd4f0002b0a67de5 /gnu
parente050aa1990ca846ccbf27327bc9009ffcfa0d578 (diff)
downloadguix-f90d6c3f69d51f10a47e78c6d57d8e59a7da337e.tar.gz
gnu: efivar: Fix build failure with GCC7.
* gnu/packages/linux.scm (efivar)[arguments]: Add phase
'kernel-headers-are-system-headers'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 23dd3f1ebd..8dd8e947ed 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4104,7 +4104,14 @@ under OpenGL graphics workloads.")
                           (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure))))
+         (delete 'configure)
+         (add-before 'build 'kernel-headers-are-system-headers
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((kernel-headers (assoc-ref inputs "kernel-headers")))
+               ;; Make sure the kernel headers are treated as system headers
+               ;; to suppress a conflict between "util.h" and <linux/fs.h>.
+             (setenv "C_INCLUDE_PATH" (string-append kernel-headers "/include"))
+             #t))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs