summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-06-07 20:20:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-08 10:37:08 +0200
commitffcd2315e4d65f41fdf593ecbda14ce6dff8c722 (patch)
tree015aff5f45efd8f4d2abc5e4aba469fd4567f873 /gnu
parentd7e0306aa5e7c8ac2f8794ab5839424911d62d52 (diff)
downloadguix-ffcd2315e4d65f41fdf593ecbda14ce6dff8c722.tar.gz
gnu: Add python-pubmed-parser.
* gnu/packages/python-xyz.scm (python-pubmed-parser): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1aad8b90ca..e48172de28 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10335,6 +10335,36 @@ you're careful.  The @code{backcall} package provides a way of specifying the
 callback signature using a prototype function.")
     (license license:bsd-3)))
 
+(define-public python-pubmed-parser
+  (package
+    (name "python-pubmed-parser")
+    (version "0.3.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/titipata/pubmed_parser")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "195cmjjg7xdwjj5455h78q7jnxnccia07a19xwndhlkxv7vk9v60"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+     (list python-lxml
+           python-numpy
+           python-requests
+           python-six
+           python-unidecode))
+    (native-inputs
+     (list python-pytest
+           python-pytest-cov))
+    (home-page "https://github.com/titipata/pubmed_parser")
+    (synopsis "Parser for Pubmed Open-Access Subset and MEDLINE XML repository")
+    (description
+     "This package provides a Python parser for Pubmed Open-Access Subset and
+MEDLINE XML repository.")
+    (license license:expat)))
+
 (define-public python-pure-eval
   (package
     (name "python-pure-eval")