summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2020-01-10 11:30:45 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-12 00:19:09 +0100
commit0de28f9ef94634f536118acc736a01a8c5ee239d (patch)
treee1069db4432f549a8a1d68eb47b64510c4e5db1c /gnu
parent9b65dea806431ec8491184c3e89bab457042a68b (diff)
downloadguix-0de28f9ef94634f536118acc736a01a8c5ee239d.tar.gz
gnu: cmake@3.15.5: Apply "cmake-curl-certificates.patch".
* gnu/packages/cmake.scm (cmake-3.15.5)[source]: Add 'patches' field.
(cmake/fixed): Turn into a deprecated alias for CMAKE-3.15.5.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cmake.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index e2c244c1a7..de49f52f2b 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -30,6 +30,7 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix utils)
+  #:use-module (guix deprecation)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system emacs)
   #:use-module (gnu packages)
@@ -207,22 +208,13 @@ and workspaces that can be used in the compiler environment of your choice.")
     (outputs '("out" "doc"))
     (properties (alist-delete 'hidden? (package-properties cmake-minimal)))))
 
-(define-public cmake/fixed
-  ;; This is a variant of CMake that fixes X.509 certificate lookup:
-  ;; <https://issues.guix.gnu.org/issue/37371>.
-  (package
-    (inherit cmake)
-    (version (string-append (package-version cmake) "-1"))
-    (source (origin
-              (inherit (package-source cmake))
-              (patches
-               (append (search-patches "cmake-curl-certificates.patch")
-                       (origin-patches (package-source cmake))))))))
-
 (define-public cmake-3.15.5
   ;; CMake 3.15.5 fixes some issues, but declare another version to
   ;; avoid triggering the rebuild of all CMake-based packages.
   ;; See <https://issues.guix.gnu.org/issue/38060>.
+  ;;
+  ;; Furthermore, this variant fixes X.509 certificate lookup:
+  ;; <https://issues.guix.gnu.org/issue/37371>.
   (package
     (inherit cmake)
     (version "3.15.5")
@@ -233,7 +225,14 @@ and workspaces that can be used in the compiler environment of your choice.")
                                   "/cmake-" version ".tar.gz"))
               (sha256
                (base32
-                "1d5y8d92axcc6rfqlsxamayfs3fc1vdby91hn5mx1kn02ppprpgv"))))))
+                "1d5y8d92axcc6rfqlsxamayfs3fc1vdby91hn5mx1kn02ppprpgv"))
+              (patches
+               (append (search-patches "cmake-curl-certificates.patch")
+                       (origin-patches (package-source cmake))))))))
+
+;; This was cmake@3.15.1 plus "cmake-curl-certificates.patch".
+(define-deprecated cmake/fixed cmake-3.15.5)
+(export cmake/fixed)
 
 (define-public emacs-cmake-mode
   (package