summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-16 10:59:21 +0200
committerDavid Thompson <dthompson2@worcester.edu>2015-09-19 08:44:13 -0400
commit70b4cf3818c9fb5abfb49df77bcafbd5406ee700 (patch)
treea71f391cff7363945782ece4544b4fc1af95eb88 /gnu
parentec79018e6831babef249ab883e9f9a71bebe1193 (diff)
downloadguix-70b4cf3818c9fb5abfb49df77bcafbd5406ee700.tar.gz
gnu: Add ruby-nenv.
* gnu/packages/ruby.scm (ruby-nenv): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6aaa5dd5ec..0127a616de 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -550,6 +550,28 @@ same log file.")
     (home-page "http://github.com/bdurand/lumberjack")
     (license license:expat)))
 
+(define-public ruby-nenv
+  (package
+    (name "ruby-nenv")
+    (version "0.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "nenv" version))
+              (sha256
+               (base32
+                "152wxwri0afwgnxdf93gi6wjl9rr5z7vwp8ln0gpa3rddbfc27s6"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:tests? #f)) ; no tests included
+    (native-inputs
+     `(("ruby-rspec" ,ruby-rspec)
+       ("bundler" ,bundler)))
+    (synopsis "Ruby interface for modifying the environment")
+    (description "Nenv provides a convenient wrapper for Ruby's ENV to modify
+and inspect the environment.")
+    (home-page "https://github.com/e2/nenv")
+    (license license:expat)))
+
 (define-public ruby-useragent
   (package
     (name "ruby-useragent")