summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-07 00:23:13 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-07 00:23:13 -0400
commit99d27a1353209c9a33f9c3ba6bd658ae1b1cc617 (patch)
tree82f8f75c324c959b386649b24ad800bcaa0a8e04 /gnu
parentecbde6505cd12025d7fe92c2c9a56b969ff3cb8e (diff)
downloadguix-99d27a1353209c9a33f9c3ba6bd658ae1b1cc617.tar.gz
gnu: emacs-realgud: Fix realgud:run-process problem.
* gnu/packages/emacs-xyz.scm (emacs-realgud)[phases]
{fix-realgud:run-process-void-error}: New phase.
{fix-autogen-script}: Return #t.
{autogen}: Likewise.
{set-home}: Likewise.
{remove-realgud-pkg.el}: Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 23876932ac..c149f9d030 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6010,22 +6010,35 @@ after buffer changes.")
      `(#:tests? #t
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-realgud:run-process-void-error
+           ;; See: https://github.com/realgud/realgud/issues/269.
+           (lambda _
+             (substitute* '("realgud/debugger/gdb/gdb.el"
+                            "realgud/debugger/gub/gub.el")
+               (("^\\(require 'load-relative\\).*" anchor)
+                (string-append anchor
+                               "(require-relative-list \
+'(\"../../common/run\") \"realgud:\")\n")))
+             #t))
          (add-after 'unpack 'fix-autogen-script
            (lambda _
              (substitute* "autogen.sh"
-               (("./configure") "sh configure"))))
+               (("./configure") "sh configure"))
+             #t))
          (add-after 'fix-autogen-script 'autogen
            (lambda _
              (setenv "CONFIG_SHELL" "sh")
              (invoke "sh" "autogen.sh")))
          (add-after 'fix-autogen-script 'set-home
            (lambda _
-             (setenv "HOME" (getenv "TMPDIR"))))
+             (setenv "HOME" (getenv "TMPDIR"))
+             #t))
          (add-before 'patch-el-files 'remove-realgud-pkg.el
            (lambda _
              ;; FIXME: `patch-el-files' crashes on this file with error:
              ;; unable to locate "bashdb".
-             (delete-file "./test/test-regexp-bashdb.el"))))
+             (delete-file "./test/test-regexp-bashdb.el")
+             #t)))
        #:include (cons* ".*\\.el$" %default-include)))
     (native-inputs
      `(("autoconf" ,autoconf)