summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-27 15:57:12 +0200
committerMarius Bakke <marius@gnu.org>2020-06-27 20:08:24 +0200
commite0bb6391a9bd55f3856fa45f23a7891d29b834ad (patch)
tree6f10a3658a4e4ca7c88fa2b7baab0266bd8928eb /gnu
parentea60beeb3d36a7fe1d8df57bd9981b98c179b19c (diff)
downloadguix-e0bb6391a9bd55f3856fa45f23a7891d29b834ad.tar.gz
gnu: ilmbase: Update to 2.5.2.
* gnu/packages/patches/ilmbase-fix-test-arm.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/graphics.scm (ilmbase): Update to 2.5.2.
[source](patches): Remove 'ilmbase-fix-test-arm.patch'.
(openexr)[arguments]: Really increase test timeout, as the previous fix was
ineffective.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/graphics.scm15
-rw-r--r--gnu/packages/patches/ilmbase-fix-test-arm.patch60
3 files changed, 9 insertions, 67 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 396629cc93..fb157c0ab1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1106,7 +1106,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/id3lib-CVE-2007-4460.patch			\
   %D%/packages/patches/id3lib-UTF16-writing-bug.patch			\
   %D%/packages/patches/ilmbase-fix-tests.patch			\
-  %D%/packages/patches/ilmbase-fix-test-arm.patch		\
   %D%/packages/patches/inetutils-hurd.patch			\
   %D%/packages/patches/inkscape-poppler-0.76.patch		\
   %D%/packages/patches/intltool-perl-compatibility.patch	\
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 0d768b8a0e..e8bff9b86a 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -359,7 +359,7 @@ many more.")
 (define-public ilmbase
   (package
     (name "ilmbase")
-    (version "2.5.0")
+    (version "2.5.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -368,9 +368,8 @@ many more.")
               (file-name (git-file-name "ilmbase" version))
               (sha256
                (base32
-                "1k50cvi3sk6gf6w713lkk2gv5cvs74vkc7s7k4z6nmyhi4g89w4y"))
-              (patches (search-patches "ilmbase-fix-tests.patch"
-                                       "ilmbase-fix-test-arm.patch"))))
+                "1vf8bqld2bpcdi99jbr043y6vp01cp3fvbiasrn66xn91mf6imbn"))
+              (patches (search-patches "ilmbase-fix-tests.patch"))))
     (build-system cmake-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
@@ -589,11 +588,15 @@ graphics.")
            (lambda _
              (chdir "OpenEXR")
              #t))
-         (add-before 'check 'increase-test-timeout
+         (add-after 'change-directory 'increase-test-timeout
            (lambda _
              ;; On armhf-linux, we need to override the CTest default
              ;; timeout of 1500 seconds for the OpenEXR.IlmImf test.
-             (setenv "CTEST_TEST_TIMEOUT" "2000")
+             (substitute* "IlmImfTest/CMakeLists.txt"
+               (("add_test\\(NAME OpenEXR\\.IlmImf.*" all)
+                (string-append
+                 all
+                 "set_tests_properties(OpenEXR.IlmImf PROPERTIES TIMEOUT 2000)")))
              #t))
          ,@(if (not (target-64bit?))
                `((add-after 'change-directory 'disable-broken-test
diff --git a/gnu/packages/patches/ilmbase-fix-test-arm.patch b/gnu/packages/patches/ilmbase-fix-test-arm.patch
deleted file mode 100644
index 2dbc55e8c4..0000000000
--- a/gnu/packages/patches/ilmbase-fix-test-arm.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-Fix a test failure on ARM platforms:
-
-https://github.com/AcademySoftwareFoundation/openexr/issues/713
-
-Taken from upstream:
-
-https://github.com/AcademySoftwareFoundation/openexr/commit/76d9839cd1b300398f8b801dfcb4bcf2f8c0096f
-
-diff --git a/OpenEXR/IlmImfTest/testHuf.cpp b/OpenEXR/IlmImfTest/testHuf.cpp
-index 4c887ee8..a93b8ea9 100644
---- a/OpenEXR/IlmImfTest/testHuf.cpp
-+++ b/OpenEXR/IlmImfTest/testHuf.cpp
-@@ -181,9 +181,9 @@ compressUncompressSubset(const unsigned short raw[], int n)
- // This DEK hash is determined from an aprior initial run of this
- // test noting its value from the assert message compressVerify().
- // 
--#define  HUF_COMPRESS_DEK_HASH_FOR_FILL4_USHRT_MAX_PLUS_ONE 2956869585U
--#define  HUF_COMPRESS_DEK_HASH_FOR_FILL4_N 3414126535U
--#define  HUF_COMPRESS_DEK_HASH_FOR_FILL5_N 169791374U
-+#define  HUF_COMPRESS_DEK_HASH_FOR_FILL4_USHRT_MAX_PLUS_ONE 2013380646U
-+#define  HUF_COMPRESS_DEK_HASH_FOR_FILL4_N 213880353U
-+#define  HUF_COMPRESS_DEK_HASH_FOR_FILL5_N 2492982090U
- 
- void
- compressVerify (const unsigned short raw[], 
-@@ -200,7 +200,7 @@ compressVerify (const unsigned short raw[],
-     // under the topic of sorting and search chapter 6.4. 
-     //
-     unsigned int compressedHash = nCompressed;
--    const char* cptr = compressed;
-+    const unsigned char* cptr = reinterpret_cast<const unsigned char*>( (const char*) compressed);
-     for (int i = 0; i < nCompressed; ++i)
-     {
-         compressedHash = 
-@@ -210,6 +210,25 @@ compressVerify (const unsigned short raw[],
-     cout << "verifying compressed checksum hash = " 
-         << compressedHash << std::endl;
- 
-+    if (compressedHash != dekHash)
-+    {
-+       cout << "hash verification failed. Got " << compressedHash << " expected " << dekHash << std::endl;
-+       const unsigned char* cptr = reinterpret_cast<const unsigned char*>( (const char*) compressed);
-+       for(int i = 0 ; i < nCompressed ; ++i )
-+       {
-+           cout << std::hex << (0xFF & (int) (*cptr++));
-+           if ( (i & 0xF) ==0 )
-+           {
-+              cout << '\n';
-+           }
-+           else
-+           {
-+              cout << ' ';
-+           }
-+       }
-+       cout << "\n";
-+    }
-+
-     assert (compressedHash == dekHash);
- }
-