summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-10 10:04:14 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-13 11:50:06 +0100
commite63ec2366578ed22a6d4c4afcff8b2bdeab21510 (patch)
tree4f0a78ca529348504fd786dbde129038b469a5e0 /gnu
parent819f08c9afb9fc37049fd2a37a9cff8e18e36396 (diff)
downloadguix-e63ec2366578ed22a6d4c4afcff8b2bdeab21510.tar.gz
gnu: Add rust-rust-embed-impl-5.
* gnu/packages/crates-io.scm (rust-rust-embed-impl-5): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 740824efe6..3f30c37af7 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -30782,6 +30782,35 @@ password hashing function.")
  Currently the conversion uses the Bitcoin base58 alphabet.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-rust-embed-impl-5
+  (package
+    (name "rust-rust-embed-impl")
+    (version "5.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "rust-embed-impl" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0rlykmykrpllkf4900wv2jfdmq3m5qqrqhw4fdlbzxrfqi0irn9y"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-proc-macro2" ,rust-proc-macro2-1)
+        ("rust-quote" ,rust-quote-1)
+        ("rust-rust-embed-utils" ,rust-rust-embed-utils-5)
+        ("rust-shellexpand" ,rust-shellexpand-2)
+        ("rust-syn" ,rust-syn-1)
+        ("rust-walkdir" ,rust-walkdir-2))))
+    (home-page "https://github.com/pyros2097/rust-embed")
+    (synopsis "Rust custom @code{Derive} macro")
+    (description
+     "This package provides a custom @code{Derive} macro which loads files
+into the Rust binary at compile time during release and loads the file from
+the file-system during development.")
+    (license license:expat)))
+
 (define-public rust-rust-embed-utils-5
   (package
     (name "rust-rust-embed-utils")