summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-05-31 19:46:22 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-04 22:34:32 +0200
commitfadbac0ecc7b7ca314a265de5a1eae07946c0d61 (patch)
tree404e406fcc4877fece1ef5931e9b13f977321dcd /gnu
parentb202fdf1316113298359a0730f9f15d85d238bf3 (diff)
downloadguix-fadbac0ecc7b7ca314a265de5a1eae07946c0d61.tar.gz
gnu: proteinortho: Set #:guile argument of 'wrap-script'.
* gnu/packages/bioinformatics.scm
  (proteinortho)[arguments]<#:phases>{wrap-programs}:
  Set #:guile argument of ‘wrap-script’.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 85f785955e..7d8496e692 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5447,9 +5447,11 @@ predicts the locations of structural units in the sequences.")
          (add-after 'install 'wrap-programs
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((path (getenv "PATH"))
-                   (out (assoc-ref outputs "out")))
+                   (out (assoc-ref outputs "out"))
+                   (guile (search-input-file inputs "bin/guile")))
                (for-each (lambda (script)
-                           (wrap-script script `("PATH" ":" prefix (,path))))
+                           (wrap-script script #:guile guile
+                                        `("PATH" ":" prefix (,path))))
                          (cons (string-append out "/bin/proteinortho")
                                (find-files out "\\.(pl|py)$"))))
              #t)))))