summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-22 19:00:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-23 14:01:30 +0100
commit084600e3ca938c1bb806bc2152bb5182b831b647 (patch)
treefcdfe307fcb9dd73d48d18022737d3c0adb5fefe /gnu
parent67d74daf0c8b7b6d786859f0be659021f0a153d8 (diff)
downloadguix-084600e3ca938c1bb806bc2152bb5182b831b647.tar.gz
gnu: Add r-rcpptoml.
* gnu/packages/cran.scm (r-rcpptoml): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 17dfb5cd4f..2ac787dbcf 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -26528,6 +26528,27 @@ jumps from the C API as well as C++ exceptions, conform to normal R function
 semantics and supports interaction with @code{ALTREP} vectors.")
     (license license:expat)))
 
+(define-public r-rcpptoml
+  (package
+    (name "r-rcpptoml")
+    (version "0.1.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "RcppTOML" version))
+       (sha256
+        (base32 "0h8517ipwqhqkhcfiyqmvsb585g01p0ra0azbpzyxip6pq6g029g"))))
+    (properties `((upstream-name . "RcppTOML")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-rcpp))
+    (home-page "http://dirk.eddelbuettel.com/code/rcpp.toml.html")
+    (synopsis "Rcpp bindings to TOML parser")
+    (description
+     "The TOML configuration format specifies an excellent format suitable for
+both human editing as well as the common uses of a machine-readable format.
+This package provides Rcpp bindings to a TOML parser.")
+    (license license:gpl2+)))
+
 (define-public r-rcppziggurat
   (package
     (name "r-rcppziggurat")