summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-25 22:03:58 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-25 22:19:00 -0500
commit16afb35ac9dbc82534930b70ffcc4eb2bf9db808 (patch)
tree8bf37ebe7b05c1547a0404ce620110da747eb5e4 /gnu
parent71b309169d484510b217b91dbd913eb33189a2ca (diff)
downloadguix-16afb35ac9dbc82534930b70ffcc4eb2bf9db808.tar.gz
gnu: adwaita-icon-theme: Fix build on non-x86_64 targets.
* gnu/packages/gnome.scm (adwaita-icon-theme)[native-inputs]: Do not provide
use 'gtk-encode-symbolic-svg' unless building for x86_64.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 332f55ce41..f66943ef97 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2944,7 +2944,7 @@ GNOME and KDE desktops to the icon names proposed in the specification.")
 
 ;; gnome-icon-theme was renamed to adwaita-icon-theme after version 3.12.0.
 (define-public adwaita-icon-theme
-  (package (inherit gnome-icon-theme)
+  (package/inherit gnome-icon-theme
     (name "adwaita-icon-theme")
     (version "40.1.1")
     (source (origin
@@ -2956,7 +2956,11 @@ GNOME and KDE desktops to the icon names proposed in the specification.")
                (base32
                 "1xpqa1rgmixlp953938d08xvf7kv36h747ysial8g65dsrp46v0b"))))
     (native-inputs
-     `(("gtk-encode-symbolic-svg" ,gtk+ "bin")))))
+     ;; The following requires the SVG pixbuf loader, provided by librsvg,
+     ;; available on x86_64 only.
+     `(,@(if (target-64bit?)
+             (list "gtk-encode-symbolic-svg" gtk+ "bin")
+             '())))))
 
 (define-public tango-icon-theme
   (package