summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-25 00:31:44 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-25 00:31:44 -0400
commit1d537c71966756fe4e15c263dea7fb2cfaadfc2b (patch)
treea65674be3c78c926dca4f6ff827ab9d4cfb8c106 /gnu
parent065a5ed677cdd1a65acae20f185d7c4bd23b1f2c (diff)
downloadguix-1d537c71966756fe4e15c263dea7fb2cfaadfc2b.tar.gz
gnu: Add ruby-benchmark-ips.
* gnu/packages/ruby.scm (ruby-benchmark-ips): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d63600571e..ba76d5019a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6021,6 +6021,27 @@ abstraction for Ruby.")
     (home-page "https://github.com/mitchellh/middleware")
     (license license:expat)))
 
+(define-public ruby-benchmark-ips
+  (package
+    (name "ruby-benchmark-ips")
+    (version "2.8.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "benchmark-ips" version))
+       (sha256
+        (base32
+         "1n9397j7kh4vvikfann1467qgksc679imlr50hax3lk1q3af8kdw"))))
+    (build-system ruby-build-system)
+    (native-inputs
+     `(("ruby-hoe" ,ruby-hoe)))
+    (synopsis "Iterations per second enhancement for the Ruby Benchmark module")
+    (description "Benchmark-ips enhances the Ruby Benchmark module with the
+iterations per second count.  For short snippets of code, it can automatically
+figure out how many times to run the code to get interesting data.")
+    (home-page "https://github.com/evanphx/benchmark-ips")
+    (license license:expat)))
+
 (define-public ruby-gherkin
   (package
     (name "ruby-gherkin")