summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-18 17:42:58 +0100
committerMarius Bakke <marius@gnu.org>2022-01-18 19:35:55 +0100
commit206c79df39a0cc6777c6ba5cac68ee1b7d5f285e (patch)
treee4e43e81bc8bfbe78aaa5e46c776c79a51684947 /gnu
parent883227dde104f00f711bb085918b91e7fd2bf30f (diff)
downloadguix-206c79df39a0cc6777c6ba5cac68ee1b7d5f285e.tar.gz
gnu: python-parse-type: Update to 0.5.2.
* gnu/packages/python-xyz.scm (python-parse-type): Update to 0.5.2.
[native-inputs]: Add PYTHON-SETUPTOOLS.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9a0295fde8..88d16567aa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2871,19 +2871,21 @@ backported for previous versions of Python from 2.4 to 3.3.")
 (define-public python-parse-type
   (package
     (name "python-parse-type")
-    (version "0.4.2")
+    (version "0.5.2")
     (source
      (origin
       (method url-fetch)
       (uri (pypi-uri "parse_type" version))
       (sha256
        (base32
-        "0g3b6gsdwnm8dpkh2vn34q6dzxm9gl908ggyzcv31n9xbp3vv5pm"))))
+        "02wclgiqky06y36b3q07b7ngpks5j0gmgl6n71ac2j2hscc0nsbz"))))
     (build-system python-build-system)
     (propagated-inputs
      (list python-six python-parse))
     (native-inputs
-     (list python-pytest python-pytest-runner))
+     ;; Use setuptools < 58 to work around
+     ;; https://github.com/jenisys/parse_type/issues/17
+     (list python-pytest python-pytest-runner python-setuptools))
     (home-page "https://github.com/jenisys/parse_type")
     (synopsis "Extended parse module")
     (description