summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-09 19:48:39 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-09 19:57:41 +0200
commit2f6504735b8f76572edf43c6a25dc6d23e013232 (patch)
treef58beabc70c182230ae6de7e480290a3e8fb2fc2 /gnu
parent297aad07fee3b3562b7a84e0bc0bc49493ce31da (diff)
downloadguix-2f6504735b8f76572edf43c6a25dc6d23e013232.tar.gz
gnu: zutils: Update to 1.9.
* gnu/packages/compression.scm (zutils): Update to 1.9.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index e5ee5e70c6..730d6a53d8 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1980,14 +1980,13 @@ reading from and writing to ZIP archives. ")
 (define-public zutils
   (package
     (name "zutils")
-    ;; Check and remove the lint-hidden-cve property when updating.
-    (version "1.8")
+    (version "1.9")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://savannah/zutils/zutils-" version ".tar.lz"))
        (sha256
-        (base32 "0dx35mv78fgqgz6sszs05ng8ipz2xy09ry9vpmka2rmy08b7x907"))))
+        (base32 "0y2wm8wqr1wi1b1fv45dn50njv4q81p6ifx0279ji1bq56qkrn2r"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
@@ -1995,8 +1994,7 @@ reading from and writing to ZIP archives. ")
        #:phases
        (modify-phases %standard-phases
          (add-before 'check 'disable-failing-tests
-           ;; XXX ‘zgrep -L’ inverts the exit status too, which the test suite
-           ;; doesn't expect.  Bug report probably stuck in moderation.
+           ;; XXX https://lists.nongnu.org/archive/html/zutils-bug/2020-07/msg00005.html
            (lambda _
              (substitute* "testsuite/check.sh"
                (("\"\\$\\{ZGREP\\}\" -N -L \"GNU\"") "true")
@@ -2011,7 +2009,6 @@ reading from and writing to ZIP archives. ")
     (native-inputs
      ;; Needed to extract the source tarball and run the test suite.
      `(("lzip" ,lzip)))
-    (properties `((lint-hidden-cve . ("CVE-2018-1000637"))))
     (home-page "https://www.nongnu.org/zutils/zutils.html")
     (synopsis "Utilities that transparently operate on compressed files")
     (description