summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-09 00:38:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-09 00:38:15 +0100
commit3b62c2804c5ca8c02de00802619766fa8fdf6948 (patch)
tree2ca9fff0cc8a0f2cfa77f7eb20b024749414c452 /gnu
parent649ea550e754d05825d7bc96e3034b165d04b305 (diff)
downloadguix-3b62c2804c5ca8c02de00802619766fa8fdf6948.tar.gz
gnu: java-ecj: Do not inherit from java-ecj-3.
* gnu/packages/java.scm (java-ecj): Do not inherit fields from java-ecj-3.
[arguments]: Merge build phases 'fix-build.xml and 'fix-prop; remove trailing #T.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm70
1 files changed, 33 insertions, 37 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 2fad09750a..7c35f146a7 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2247,43 +2247,39 @@ Main-Class: org.eclipse.jdt.internal.compiler.batch.Main\n"
     (license license:epl1.0)))
 
 (define-public java-ecj
-  (package (inherit java-ecj-3)
-           (version "4.6.3")
-           (source
-            (origin
-              (method url-fetch)
-              (uri (string-append
-                    "http://archive.eclipse.org/eclipse/downloads/drops4/R-"
-                    version
-                    "-201703010400/ecjsrc-"
-                    version
-                    ".jar"))
-              (sha256
-               (base32
-                "11cfgsdgznja1pvlxkjbqykxd7pcd5655vkm7s44xmahmap15gpl"))))
-           (arguments
-            `(#:tests? #f ; none included
-              #:build-target "build"
-              #:phases
-              (modify-phases %standard-phases
-                (add-after 'unpack 'fix-build.xml
-                  (lambda _
-                    (substitute* "src/build.xml"
-                      (("^.*MANIFEST.*$")
-                       ""))
-                    #t))
-                (add-after 'unpack 'fix-prop
-                  (lambda _
-                    (substitute* "src/build.xml"
-                      (("^.*properties.*$")
-                       "<include name=\"**/*.properties\"/>
- <include name=\"**/*.props\"/>"))
-                    #t))
-                (add-before 'build 'chdir
-                  (lambda _
-                    (chdir "src")
-                    #t))
-                (replace 'install (install-jars ".")))))))
+  (package
+    (name "java-ecj")
+    (version "4.6.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://archive.eclipse.org/eclipse/"
+                           "downloads/drops4/R-" version "-201703010400/"
+                           "ecjsrc-" version ".jar"))
+       (sha256
+        (base32
+         "11cfgsdgznja1pvlxkjbqykxd7pcd5655vkm7s44xmahmap15gpl"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:tests? #f                      ; none included
+       #:build-target "build"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-build.xml
+           (lambda _
+             (substitute* "src/build.xml"
+               (("^.*MANIFEST.*$")
+                "")
+               (("^.*properties.*$")
+                "<include name=\"**/*.properties\"/>
+ <include name=\"**/*.props\"/>"))))
+         (add-before 'build 'chdir
+           (lambda _ (chdir "src")))
+         (replace 'install (install-jars ".")))))
+    (home-page "https://eclipse.org")
+    (synopsis "Eclipse Java development tools core batch compiler")
+    (description "This package provides the Eclipse Java core batch compiler.")
+    (license license:epl1.0)))
 
 (define-public java-cisd-base
   (let ((revision 38938)