summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-29 19:26:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 00:20:33 -0400
commit3f25fcf84d5097dd66006db9204187376ea90e23 (patch)
treeec7e509773a4adecc8497189a8ec858c2faace7f /gnu
parent164dfdc44e2bc56c5a257d61d6bb8b84c1b0add1 (diff)
downloadguix-3f25fcf84d5097dd66006db9204187376ea90e23.tar.gz
gnu: upower: Fix indentation.
* gnu/packages/gnome.scm (upower): Fix indentation.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm37
1 files changed, 18 insertions, 19 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e21eca2e2a..8b2d29b5c4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5514,30 +5514,29 @@ faster results and to avoid unnecessary server load.")
         (base32 "1g17rm91p8vfpjyb0k2shylrs55nccn3fa890vlk4n9s71sghbzq"))
        (modules '((guix build utils)))
        (snippet
-         ;; Upstream commit
-         ;; <https://cgit.freedesktop.org/upower/commit/?id=18457c99b68786cd729b315723d680e6860d9cfa>
-         ;; moved 'dbus-1/system.d' from etc/ to share/.  However,
-         ;; 'dbus-configuration-directory' in (gnu services dbus)
-         ;; expects it in etc/.  Thus, move it back to its previous
-         ;; location.
-         #~(substitute* "src/meson.build"
+        ;; Upstream commit <https://cgit.freedesktop.org/upower/commit/
+        ;; ?id=18457c99b68786cd729b315723d680e6860d9cfa> moved
+        ;; 'dbus-1/system.d' from etc/ to share/.  However,
+        ;; 'dbus-configuration-directory' in (gnu services dbus) expects it in
+        ;; etc/.  Thus, move it back to its previous location.
+        #~(substitute* "src/meson.build"
             (("dbusdir / 'system.d'")
-              "get_option('sysconfdir') / 'dbus-1/system.d'")
+             "get_option('sysconfdir') / 'dbus-1/system.d'")
             ;; Avoid writing to /var during the build, this is
             ;; not possible in Guix!
             (("^install_subdir\\('does-not-exist'.*$") "")))))
     (build-system meson-build-system)
     (arguments
-      (list
-       #:glib-or-gtk? #t
-       #:configure-flags
-       #~(list "-Dsystemdsystemunitdir=no"
-               ;; If not specified, udev will try putting history information
-               ;; in /gnu/store.
-               "-Dhistorydir=/var/lib/upower"
-               (string-append "-Dudevrulesdir=" #$output "/bin/udev/rules.d"))))
+     (list
+      #:glib-or-gtk? #t
+      #:configure-flags
+      #~(list "-Dsystemdsystemunitdir=no"
+              ;; If not specified, udev will try putting history information
+              ;; in /gnu/store.
+              "-Dhistorydir=/var/lib/upower"
+              (string-append "-Dudevrulesdir=" #$output "/bin/udev/rules.d"))))
     (native-inputs
-     (list `(,glib "bin") ; for gdbus-codegen
+     (list `(,glib "bin")               ; for gdbus-codegen
            gobject-introspection
            gtk-doc
            intltool
@@ -5551,8 +5550,8 @@ faster results and to avoid unnecessary server load.")
            umockdev
            ;; For man pages.
            docbook-xsl
-           libxslt ; for 'xsltproc'
-           libxml2))           ; for 'XML_CATALOG_FILES'
+           libxslt                      ; for 'xsltproc'
+           libxml2))                    ; for 'XML_CATALOG_FILES'
     (inputs
      (list dbus-glib libgudev libusb))
     (propagated-inputs