summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:14 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:56 +0000
commit419023489e9ba39cf115fcdfbdbc109633bf09c9 (patch)
treefe96fecb9251c9e1e147d01091ef99661c2e76de /gnu
parent5f0d2ed20b31d58a53e907ff54342d0c72ef4198 (diff)
downloadguix-419023489e9ba39cf115fcdfbdbc109633bf09c9.tar.gz
gnu: Add ocaml-async-kernel.
* gnu/packages/ocaml.scm (ocaml-async-kernel): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 521a98e583..304c900af5 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8389,6 +8389,30 @@ the full Core is not available, such as in Javascript.")
 core_kernel.")
     (license license:expat)))
 
+(define-public ocaml-async-kernel
+  (package
+    (name "ocaml-async-kernel")
+    (version "0.15.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/janestreet/async_kernel")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "01if6c8l2h64v7sk56xr8acnmj6g9whxcjrzzzvczspq88hq2bfh"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-core ocaml-core-kernel ocaml-ppx-jane))
+    (properties `((upstream-name . "async_kernel")))
+    (home-page "https://github.com/janestreet/async_kernel")
+    (synopsis "Monadic concurrency library")
+    (description
+     "Contains @code{Async}'s core data structures, like
+@code{Deferred}.  @code{Async_kernel} is portable, and so can be used in
+JavaScript using @code{Async_js}.")
+    (license license:expat)))
+
 (define-public ocaml-timezone
   (package
     (name "ocaml-timezone")