summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-15 13:20:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-15 13:20:45 +0300
commit5254e375422750c8588b44eec07a6eb62e740abf (patch)
treef5514047a365f339ee85587e79890e122f57376b /gnu
parentf560a09fa31cb01de00422402eabcb2b22290e23 (diff)
downloadguix-5254e375422750c8588b44eec07a6eb62e740abf.tar.gz
gnu: python-trio: Update to 0.19.0.
* gnu/packages/python-xyz.scm (python-trio): Update to 0.19.0.
[arguments]: Adjust skipped tests.
[propagated-inputs]: Add python-async-generator.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f89e554d6d..62fffda38a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22598,13 +22598,13 @@ project.")
 (define-public python-trio
   (package
     (name "python-trio")
-    (version "0.17.0")
+    (version "0.19.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "trio" version))
        (sha256
-        (base32 "0zcxirpdvvl54pbfkgw7vz984879xwvdygqfpggnam24is2zjp78"))))
+        (base32 "1qgg4zhca81dxc1nlmcr5pl1bclmvdp3niqbyslwxs65bs732pl9"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -22623,6 +22623,9 @@ project.")
                      ;; Assertion errors.
                      " and not test_guest_mode_ki"
                      " and not test_run_in_trio_thread_ki"
+                     " and not test_simple_cancel_scope_usage_doesnt_create_cyclic_garbage"
+                     " and not test_nursery_cancel_doesnt_create_cyclic_garbage"
+                     " and not test_locals_destroyed_promptly_on_cancel"
                      ;; These try to raise KeyboardInterrupt which does not work
                      ;; in the build environment.
                      " and not test_ki_self"
@@ -22642,7 +22645,8 @@ project.")
        ("python-pytest-cov" ,python-pytest-cov)
        ("python-trustme" ,python-trustme)))
     (propagated-inputs
-     `(("python-attrs" ,python-attrs)
+     `(("python-async-generator" ,python-async-generator)
+       ("python-attrs" ,python-attrs)
        ("python-idna" ,python-idna)
        ("python-outcome" ,python-outcome)
        ("python-sniffio" ,python-sniffio)