summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-02-28 16:43:59 +0100
committerLudovic Courtès <ludo@gnu.org>2018-02-28 22:47:48 +0100
commit63e48300d19b848dfe75880581338c2c73b7b0df (patch)
treea4633c0a1ad42584c512a53338f02c3870cde9eb /gnu
parent297602513bf023e485a496bbb813cb9cafdf7475 (diff)
downloadguix-63e48300d19b848dfe75880581338c2c73b7b0df.tar.gz
gnu: guile-static-stripped: Remove dependency on bash-minimal.
Previously guile-static-stripped, which is embedded in the initrd, would
depend on 'bash-minimal' and 'glibc'; the closure size was 77 MiB.  Now
the closure size is down to 45.7 MiB.

Reported by Danny Milosavljevic <dannym@scratchpost.org> in
<https://lists.gnu.org/archive/html/guix-devel/2018-02/msg00505.html>.

* gnu/packages/make-bootstrap.scm (%guile-static): Remove the
'pre-configure' phase.
(%guile-static-stripped)[arguments]: Add #:allowed-references.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/make-bootstrap.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index f1c4bf7bc5..779b7ef5aa 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -532,6 +532,13 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
                       ''("LDFLAGS=-ldl"))
                      ((#:phases phases '%standard-phases)
                       `(modify-phases ,phases
+
+                         ;; Do not record the absolute file name of 'sh' in
+                         ;; (ice-9 popen).  This makes 'open-pipe' unusable in
+                         ;; a build chroot ('open-pipe*' is fine) but avoids
+                         ;; keeping a reference to Bash.
+                         (delete 'pre-configure)
+
                          (add-before 'configure 'static-guile
                            (lambda _
                              (substitute* "libguile/Makefile.in"
@@ -557,7 +564,9 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
     (name "guile-static-stripped")
     (build-system trivial-build-system)
     (arguments
-     `(#:modules ((guix build utils))
+     ;; The end result should depend on nothing but itself.
+     `(#:allowed-references ("out")
+       #:modules ((guix build utils))
        #:builder
        (let ()
          (use-modules (guix build utils))