summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-20 01:16:53 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:06 -0400
commit70bb54c8a2565df6e14cc8f453b4c3daeaf07214 (patch)
tree6f01f1912bafd42af30338c347b1513a7626debb /gnu
parent075dbc8734dcfc5843330f7efddc733afb746ace (diff)
downloadguix-70bb54c8a2565df6e14cc8f453b4c3daeaf07214.tar.gz
gnu: Remove python2-keyring.
* gnu/packages/python-crypto.scm (python2-keyring): Delete variable.
(python-keyring)[properties]: Delete field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-crypto.scm22
1 files changed, 0 insertions, 22 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 60879f1c52..7f358659f0 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -366,30 +366,8 @@ do what is needed for client/server Kerberos authentication based on
 service from python.  It can be used in any application that needs safe
 password storage.")
     ;; "MIT" and PSF dual license
-    (properties `((python2-variant . ,(delay python2-keyring))))
     (license license:x11)))
 
-(define-public python2-keyring
-  (let ((keyring (package-with-python2
-                   (strip-python2-variant python-keyring))))
-    (package
-      (inherit keyring)
-      (name "python2-keyring")
-      (version "8.7")
-      (source
-        (origin
-          (method url-fetch)
-          (uri (pypi-uri "keyring" version))
-          (sha256
-           (base32
-            "0482rmi2x6p78wl2kz8qzyq21xz1sbbfwnv5x7dggar4vkwxhzfx"))))
-      (arguments
-       `(#:python ,python-2))
-      (native-inputs
-       (list python2-pytest python2-pytest-runner python2-setuptools-scm))
-      (propagated-inputs
-       (list python2-pycrypto)))))
-
 (define-public python-keyrings.alt
   (package
     (name "python-keyrings.alt")