summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-07-22 00:08:52 +0200
committerMarius Bakke <marius@gnu.org>2021-07-23 17:26:47 +0200
commit71ec85b2958798246fc2b5d84c40badf5f75668e (patch)
tree88b37a3b6119680c6c5b3fb934576dcccdd11029 /gnu
parent79c28121306ee26856414724b1efe0ed65318085 (diff)
downloadguix-71ec85b2958798246fc2b5d84c40badf5f75668e.tar.gz
gnu: Python: Disable indeterministic optimizations.
* gnu/packages/python.scm (python-2.7)[arguments]: Remove "--with-lto" and
"--enable-optimizations" from #:configure-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index cee8613b34..f4d574e2b2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -187,9 +187,12 @@
              "--with-system-ffi"        ;build ctypes
              "--with-ensurepip=install" ;install pip and setuptools
              "--with-computed-gotos"    ;main interpreter loop optimization
-             "--with-lto"               ;increase size by 20MB, but 15% speedup
              "--enable-unicode=ucs4"
-             "--enable-optimizations"
+
+             ;; FIXME: These flags makes Python significantly faster, but
+             ;; leads to non-reproducible binaries.
+             ;; "--with-lto"               ;increase size by 20MB, but 15% speedup
+             ;; "--enable-optimizations"
 
              ;; Prevent the installed _sysconfigdata.py from retaining a reference
              ;; to coreutils.