summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-24 23:54:00 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-24 23:55:28 +0200
commit74c8b174e8015de753ba5cab44f76f944e6fd4ba (patch)
tree6138bad97ff00da27f56a1585e0e70ef13ed1408 /gnu
parent875715cabfeb7816cea16269cfbdbad08442a73e (diff)
downloadguix-74c8b174e8015de753ba5cab44f76f944e6fd4ba.tar.gz
gnu: Adjust to PCRE split.
This is a followup to commit 6d49ca3bad613700b539c30272e164207455735b.

* gnu/packages/databases.scm (4store)[inputs]: Remove PCRE.
[native-inputs]: Add PCRE:bin.
* gnu/packages/web.scm (httpd): Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/databases.scm2
-rw-r--r--gnu/packages/web.scm2
2 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 8a902546fc..4f2f211fb3 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -86,6 +86,7 @@
        ("automake" ,automake)
        ("gettext" ,gnu-gettext)
        ("libtool" ,libtool)
+       ("pcre" ,pcre "bin")                       ;for 'pcre-config'
        ("pkg-config" ,pkg-config)))
     (inputs
      `(("glib" ,glib)
@@ -94,7 +95,6 @@
        ("raptor2" ,raptor2)
        ("readline" ,readline)
        ("avahi" ,avahi)
-       ("pcre" ,pcre)
        ("cyrus-sasl" ,cyrus-sasl)
        ("openssl" ,openssl)
        ("util-linux" ,util-linux)))
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 9f36fce027..3e145fc5d7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -84,10 +84,10 @@
               (base32
                "0hrpy6gjwma0kba7p7m61vwh82qcnkf08123lrwpg257m93hnrmc"))))
     (build-system gnu-build-system)
+    (native-inputs `(("pcre" ,pcre "bin")))       ;for 'pcre-config'
     (inputs `(("apr" ,apr)
               ("apr-util" ,apr-util)
               ("openssl" ,openssl)
-              ("pcre" ,pcre)
               ("perl" ,perl))) ; needed to run bin/apxs
     (arguments
      `(#:test-target "test"