summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-04-27 10:08:00 +0200
committerLudovic Courtès <ludo@gnu.org>2016-04-27 11:57:48 +0200
commit7de1f10363bab159c77b5728743703b4c1614848 (patch)
tree975c392e09b123a9cd9029a50dc7f3443525012d /gnu
parent20be23c3b67dd181a2c4b468626490a7eb74e492 (diff)
downloadguix-7de1f10363bab159c77b5728743703b4c1614848.tar.gz
gnu: Add missing synopses and descriptions.
* gnu/packages/bootstrap.scm (package-from-tarball)
(%bootstrap-glibc, %bootstrap-gcc): Set 'description' field.
* gnu/packages/make-bootstrap.scm (%bootstrap-tarballs): Set 'synopsis'
and 'description'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bootstrap.scm8
-rw-r--r--gnu/packages/make-bootstrap.scm6
2 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 1ada01c904..3f3770d89b 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -125,7 +125,7 @@ successful, or false to signal an error."
        ("tarball" ,(bootstrap-origin (source (%current-system))))))
     (source #f)
     (synopsis description)
-    (description #f)
+    (description description)
     (home-page #f)
     (license gpl3+)))
 
@@ -411,7 +411,7 @@ $out/bin/guile --version~%"
                          (base32
                           "0k97a3whzx3apsi9n2cbsrr79ad6lh00klxph9hw4fqyp1abkdsg")))))))))
     (synopsis "Bootstrap binaries and headers of the GNU C Library")
-    (description #f)
+    (description synopsis)
     (home-page #f)
     (license lgpl2.1+)))
 
@@ -496,7 +496,7 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
             (variable "LIBRARY_PATH")
             (files '("lib" "lib64")))))
     (synopsis "Bootstrap binaries of the GNU Compiler Collection")
-    (description #f)
+    (description synopsis)
     (home-page #f)
     (license gpl3+)))
 
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index b3c86dbebf..85dfaa6b6f 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -683,8 +683,8 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
               ("binutils-tarball" ,%binutils-bootstrap-tarball)
               ("glibc-tarball" ,%glibc-bootstrap-tarball)
               ("coreutils&co-tarball" ,%bootstrap-binaries-tarball)))
-    (synopsis #f)
-    (description #f)
+    (synopsis "Tarballs containing all the bootstrap binaries")
+    (description synopsis)
     (home-page #f)
     (license gpl3+)))