summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-06 22:06:36 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-06 22:06:36 +0200
commit86e278fc1ac9b261468081e89cbd6b695f98a71c (patch)
tree5182202ecc207a8322de6184f6d1bd44947fbe70 /gnu
parentef1c4148384c66cb99facd8a20ca1dc73644926a (diff)
downloadguix-86e278fc1ac9b261468081e89cbd6b695f98a71c.tar.gz
gnu: Add libmspub.
* gnu/packages/libreoffice.scm (libmspub): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/libreoffice.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 2f7b4d7e99..9027a83864 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -332,3 +332,29 @@ library primarily intended for language guessing.")
     (description "Libfreehand is a library that parses the file format of
 Aldus/Macromedia/Adobe FreeHand documents.")
     (license mpl2.0)))
+
+(define-public libmspub
+  (package
+    (name "libmspub")
+    (version "0.1.2")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
+                          name "-" version ".tar.xz"))
+      (sha256 (base32
+               "03sn6lxpr49sdq6j8q7fw7yjybyfahhs03z80388mh105pwapfmh"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("doxygen" ,doxygen)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("boost" ,boost)
+       ("icu4c" ,icu4c)
+       ("librevenge" ,librevenge)
+       ("zlib" ,zlib)))
+    (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libmspub")
+    (synopsis "Library for parsing the Microsoft Publisher format")
+    (description "Libmspub is a library that parses the file format of
+Microsoft Publisher documents of all versions.")
+    (license mpl2.0)))