summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-16 12:39:18 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-16 16:19:39 +0100
commit88ca4029a676a99325085a7ecede63d8b011de8f (patch)
treefa043f76aff97fb09e108c58ac47a49fdd992de1 /gnu
parentc6a7fe7937a3db3ade7ced40c08dd674fbf5cf9c (diff)
downloadguix-88ca4029a676a99325085a7ecede63d8b011de8f.tar.gz
gnu: iw: Fix cross-compilation.
* gnu/packages/linux.scm (iw)[arguments]: Set PKG_CONFIG and CC variables
correctly for cross-compilation.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c70aa6c815..a062e2ba55 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2071,8 +2071,18 @@ configuration and monitoring interfaces.")
     (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs `(("libnl" ,libnl)))
     (arguments
-     `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
-                          "CC=gcc")
+     `(#:make-flags
+       (let* ((target ,(%current-target-system))
+              (gcc (if target (string-append target "-gcc") "gcc"))
+              (pkg-config (if target
+                              (string-append target "-pkg-config")
+                              "pkg-config")))
+         (list
+          (string-append "CC=" gcc)
+          (string-append "PKG_CONFIG="
+                         (assoc-ref %build-inputs "pkg-config")
+                         "/bin/" pkg-config)
+          (string-append "PREFIX=" (assoc-ref %outputs "out"))))
        #:phases (modify-phases %standard-phases (delete 'configure))))
     (home-page "https://wireless.wiki.kernel.org/")
     (synopsis "Tool for configuring wireless devices")