summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-19 00:16:33 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-19 00:21:41 +0200
commit9e371e9595954a42049814e13bbaf2a639eb20b8 (patch)
treed9befdefcb4f0c40d0c87b2578127baced36c470 /gnu
parentaffae3241cae7f76b583e838b8e9b7721a6f59ef (diff)
downloadguix-9e371e9595954a42049814e13bbaf2a639eb20b8.tar.gz
Disambiguate ‘expat’ in (gnu packages man).
This follows up on commit e445ae9ae13dc33f3770324c58cb91cd89185846.

* gnu/packages/man.scm: Import (guix licences) with a ‘license:’ prefix.
Adjust all users.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/man.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 45c8baef31..18aa3abe79 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -25,7 +25,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages man)
-  #:use-module (guix licenses)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix git-download)
   #:use-module (guix download)
   #:use-module (guix packages)
@@ -72,7 +72,7 @@
 to man pages in groff format or html.  It features the usual man page items such
 as description, options, see also, etc.")
     (home-page "http://xmltoman.sourceforge.net/")
-    (license gpl2+)))
+    (license license:gpl2+)))
 
 (define-public ronn
   (package
@@ -96,7 +96,7 @@ as description, options, see also, etc.")
     (description "Ronn builds manuals.  It converts simple, human readable
 textfiles to roff for terminal display, and also to HTML for the web.")
     (home-page "https://rtomayko.github.io/ronn/")
-    (license expat)))
+    (license license:expat)))
 
 (define-public libpipeline
   (package
@@ -116,7 +116,7 @@ textfiles to roff for terminal display, and also to HTML for the web.")
     (description
      "libpipeline is a C library for manipulating pipelines of subprocesses in
 a flexible and convenient way.")
-    (license gpl3+)))
+    (license license:gpl3+)))
 
 (define-public man-db
   (package
@@ -218,7 +218,7 @@ a flexible and convenient way.")
      "Man-db is an implementation of the standard Unix documentation system
 accessed using the man command.  It uses a Berkeley DB database in place of
 the traditional flat-text whatis databases.")
-    (license gpl2+)))
+    (license license:gpl2+)))
 
 (define-public man-pages
   (package
@@ -254,7 +254,7 @@ the traditional flat-text whatis databases.")
 Linux kernel and C library interfaces employed by user-space programs.")
 
     ;; Each man page has its own license; some are GPLv2+, some are MIT/X11.
-    (license gpl2+)))
+    (license license:gpl2+)))
 
 (define-public help2man
   (package
@@ -285,7 +285,7 @@ Linux kernel and C library interfaces employed by user-space programs.")
      "GNU help2man is a program that converts the output of standard
 \"--help\" and \"--version\" command-line arguments into a manual page
 automatically.")
-    (license gpl3+)))
+    (license license:gpl3+)))
 
 (define-public scdoc
   (package
@@ -312,7 +312,7 @@ automatically.")
    (description "scdoc is a simple man page generator written for POSIX systems
 in C99.")
    ;; MIT license, see /share/doc/scdoc-1.6.0/COPYING.
-   (license expat)))
+   (license license:expat)))
 
 (define-public txt2man
   (package
@@ -338,4 +338,4 @@ in C99.")
     (home-page "https://github.com/mvertes/txt2man")
     (synopsis "Convert text to man page")
     (description "Txt2man converts flat ASCII text to man page format.")
-    (license gpl2+)))
+    (license license:gpl2+)))