summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorswedebugia <swedebugia@riseup.net>2019-08-01 22:31:42 +0200
committerLudovic Courtès <ludo@gnu.org>2019-08-22 17:59:30 +0200
commitaf012922776cc249be45604aa295ac086a243473 (patch)
treeb50bb29cf0121fd6c8b01c1eebdf62488fe42851 /gnu
parent6d0fb469ed9de2ec9d51ba0631f4b9b42b7f6f88 (diff)
downloadguix-af012922776cc249be45604aa295ac086a243473.tar.gz
gnu: Add bitcoin-abc.
* gnu/packages/finance.scm (bitcoin-abc): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/finance.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index fc26b77279..377cb3a405 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1111,3 +1111,31 @@ information.")
     (description "This allows a Trezor hardware wallet to communicate to the
 Trezor wallet.")
     (license license:lgpl3+)))
+
+(define-public bitcoin-abc
+  (package
+    (inherit bitcoin-core)
+    (name "bitcoin-abc")
+    (version "0.19.8")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://download.bitcoinabc.org/"
+                                  version "/linux/src/bitcoin-abc-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0ndvkxv5m8346bdhfqzgdiz1k9wyjycj05jp7daf9pml3cw79sz5"))))
+    (home-page "https://www.bitcoinabc.org/")
+    (synopsis "Bitcoin ABC peer-to-peer full node for the Bitcoin Cash protocol")
+    (description
+     "Bitcoin Cash brings sound money to the world, fulfilling the original
+promise of Bitcoin as Peer-to-Peer Electronic Cash.  Merchants and users are
+empowered with low fees and reliable confirmations is a digital currency that
+enables instant payments to anyone anywhere in the world.  It uses
+peer-to-peer technology to operate without central authority: managing
+transactions and issuing money are carried out collectively by the network.
+As a fork it implemented changes lowering the time between blocks and now
+offers confimations after less than 5 seconds and have significantly lower
+fees that BTC.  Bitcoin ABC is the reference implementation of the Bitcoin
+Cash protocol.  This package provides the Bitcoin Cash command line client and
+a client based on Qt.  This is a fork of Bitcoin Core.")))