summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-05 17:42:52 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:35 -0400
commitb74f837118e78dd59d047fd643476658adb5da17 (patch)
tree5cccb7d8caf342b10d54d11d8fb6e1b8c52a8d64 /gnu
parent314444917bea8ba9fe62a4ab3dba2c64475117b1 (diff)
downloadguix-b74f837118e78dd59d047fd643476658adb5da17.tar.gz
gnu: gnome-font-viewer: Update to 42.0.
* gnu/packages/gnome.scm (gnome-font-viewer): Update to 42.0.
[phases]: Delete trailing #t.  Use gexps.
{patch-thumbnailer}: Use search-input-file.
[native-inputs]: Delete labels.
[inputs]: Replace gtk+ with gtk.  Add libadwaita.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm49
1 files changed, 25 insertions, 24 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8875f3c021..43f14a29ab 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2287,7 +2287,7 @@ The gnome-about program helps find which version of GNOME is installed.")
 (define-public gnome-font-viewer
   (package
     (name "gnome-font-viewer")
-    (version "40.0")
+    (version "42.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/gnome-font-viewer/"
@@ -2295,33 +2295,34 @@ The gnome-about program helps find which version of GNOME is installed.")
                                   "/gnome-font-viewer-" version ".tar.xz"))
               (sha256
                (base32
-                "0hpyi0sz3gcqqs9lkwyk8b6hr39m3n27432x98kxr436jj37dk6j"))))
+                "1k4dhk5dmkpxb5xpr9vrl7k2fdpi2fidzni1l2hhb891zzgvi8ng"))))
     (build-system meson-build-system)
     (arguments
-     `(#:meson ,meson-0.60
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-post-install-script
-           (lambda _
-             (substitute* "meson-postinstall.sh"
-               (("update-desktop-database") (which "true")))
-             #t))
-         (add-after 'install 'patch-thumbnailer
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (substitute*
-                   (string-append
-                    out
-                    "/share/thumbnailers/gnome-font-viewer.thumbnailer")
-                 (("gnome-thumbnail-font")
-                  (string-append out "/bin/gnome-thumbnail-font"))))
-             #t)))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-post-install-script
+            (lambda _
+              (substitute* "meson-postinstall.sh"
+                (("update-desktop-database") (which "true")))))
+          (add-after 'install 'patch-thumbnailer
+            (lambda* (#:key outputs #:allow-other-keys)
+              (substitute*
+                  (search-input-file
+                   outputs "share/thumbnailers/gnome-font-viewer.thumbnailer")
+                (("gnome-thumbnail-font")
+                 (search-input-file outputs "bin/gnome-thumbnail-font"))))))))
     (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("glib:bin" ,glib "bin")
-       ("pkg-config" ,pkg-config)))
+     (list gettext-minimal
+           `(,glib "bin")
+           pkg-config))
     (inputs
-     (list glib gnome-desktop gtk+ libhandy libxml2))
+     (list glib
+           gnome-desktop
+           gtk
+           libadwaita
+           libhandy
+           libxml2))
     (home-page "https://gitlab.gnome.org/GNOME/gnome-font-viewer")
     (synopsis "GNOME Fonts")
     (description "Application to show you the fonts installed on your computer