summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-20 11:24:57 +0100
committerMarius Bakke <marius@gnu.org>2020-11-20 11:27:06 +0100
commitcc055349466d56e042c2e71c310142f91aaf78cf (patch)
tree46b64b3c1be3b928ad909cb060539e44a35f38c7 /gnu
parentc8eb362477e17686d148dd71b530589215b81683 (diff)
downloadguix-cc055349466d56e042c2e71c310142f91aaf78cf.tar.gz
gnu: python2-html2text: Downgrade to 2019.8.11.
* gnu/packages/python-web.scm (python2-html2text): Don't inherit version and
source from PYTHON-HTML2TEXT.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 121e42d663..15b53c2be2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -485,7 +485,17 @@ Swartz.")
     (license license:gpl3+)))
 
 (define-public python2-html2text
-  (package-with-python2 python-html2text))
+  (let ((base (package-with-python2 python-html2text)))
+    (package
+      (inherit base)
+      ;; This is the last version with support for Python 2.
+      (version "2019.8.11")
+      (source (origin
+                (method url-fetch)
+                (uri (pypi-uri "html2text" version))
+                (sha256
+                 (base32
+                  "0ppgjplg06kmv9sj0x8p7acczcq2mcfgk1jdjwm4w5w40b0vj5pm")))))))
 
 (define-public python-mechanicalsoup
   (package