summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNiklas Eklund <niklas.eklund@posteo.net>2022-02-02 19:49:46 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-03 23:57:01 +0100
commitd6a0713331e94cd7fcbe91d864ee6aa40526859e (patch)
treed1a4297abed86b584e779031c0087297e05d2f18 /gnu
parent17c3bc1955561411534fd3ce3a00b490ad166cc2 (diff)
downloadguix-d6a0713331e94cd7fcbe91d864ee6aa40526859e.tar.gz
gnu: Add emacs-spell-fu.
* gnu/packages/emacs-xyz.scm (emacs-spell-fu): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9a0892b788..a9b5129e29 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27011,6 +27011,30 @@ interfaces.  Several interfaces are supported beside the classic Ido: Popup,
 Helm and Ivy.")
     (license license:gpl3+)))
 
+(define-public emacs-spell-fu
+  ;; There are no tagged releases upstream on gitlab, instead we are using the
+  ;; most recent commit.
+  (let ((commit "50be652a6ec8590c3098f46094a92213623349c1") (revision "0"))
+    (package
+      (name "emacs-spell-fu")
+      (version (git-version "0.3" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://gitlab.com/ideasman42/emacs-spell-fu")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0n7qwnirvkh2aprb7l1wj9rywdsn33a7s32716m3afcvy7z9pyh4"))))
+      (build-system emacs-build-system)
+      (home-page "https://gitlab.com/ideasman42/emacs-spell-fu")
+      (synopsis "Fast highlighting of misspelled words")
+      (description
+       "This is a light weight spell checker for Emacs,
+that runs from the syntax highlighter without starting external processes.")
+      (license license:gpl3+))))
+
 (define-public emacs-org-emms
   (let ((commit "07a8917f3d628c32e5de1dbd118ac08203772533")
         (revision "1"))