summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-11-30 22:25:54 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-11-30 22:31:37 +0100
commitd6e40862ccbf9af76989be9ede94a0163a29055c (patch)
treea4ebadeca6188f1ff658c2cac023ca116dc03622 /gnu
parentb5ed51bdf93de46e0852fda3738690f820ada439 (diff)
downloadguix-d6e40862ccbf9af76989be9ede94a0163a29055c.tar.gz
gnu: Add go-github.com-ulikunitz-xz.
* gnu/packages/golang.scm (go-github.com-ulikunitz-xz): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 92533cfd50..94b6fb814e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6041,3 +6041,25 @@ JSON data to the machine.")
 systems can import this package to enable running programs as services without
 modifying them.")
     (license license:zlib)))
+
+(define-public go-github.com-ulikunitz-xz
+  (package
+    (name "go-github.com-ulikunitz-xz")
+    (version "0.5.8")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ulikunitz/xz.git")
+                    (commit (string-append "v" version))))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "1xnsymi5fmmm734bi4c6z57p5cvnyxlpi29yxs4v21w5k763aypd"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/ulikunitz/xz"))
+    (synopsis "Read and write xz compressed streams in Go")
+    (description "This package provides a library to read and write xz
+compressed streams in Go.")
+    (home-page "https://github.com/ulikunitz/xz")
+    (license license:bsd-3)))