summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-01 22:07:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-01 22:16:43 +0300
commitde429a93429fef13727bc84c1cab8a3fbbe150dd (patch)
tree79c8f31748555bb483e23c46f55a9a7e7423a422 /gnu
parent0b7f9806dbde1a7c1ded4218e499319d7eafbe7a (diff)
downloadguix-de429a93429fef13727bc84c1cab8a3fbbe150dd.tar.gz
gnu: ruby: Update to 2.4.2.
* gnu/packages/ruby.scm (ruby): Update to 2.4.2.
[replacement]: Remove field.
(ruby-2.4.2): Remove variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 3 insertions, 23 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0193076291..56504520cb 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2015, 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
 ;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -49,8 +50,7 @@
 (define-public ruby
   (package
     (name "ruby")
-    (replacement ruby-2.4.2)
-    (version "2.4.0")
+    (version "2.4.2")
     (source
      (origin
        (method url-fetch)
@@ -59,7 +59,7 @@
                            "/ruby-" version ".tar.xz"))
        (sha256
         (base32
-         "141nnsdk2q83c23p5kl404id8gy1ap261gin48rbjj5sbksgx1rs"))
+         "0dgp4ypk3smrsbh2c249n5pl6nqhpd2igq9484dbsh81sf08k2kl"))
        (modules '((guix build utils)))
        (snippet `(begin
                    ;; Remove bundled libffi
@@ -103,26 +103,6 @@ a focus on simplicity and productivity.")
     (home-page "https://ruby-lang.org")
     (license license:ruby)))
 
-(define-public ruby-2.4.2
-  (package
-    (inherit ruby)
-    (name "ruby")
-    (version "2.4.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "http://cache.ruby-lang.org/pub/ruby/"
-                           (version-major+minor version)
-                           "/ruby-" version ".tar.xz"))
-       (sha256
-        (base32
-         "0dgp4ypk3smrsbh2c249n5pl6nqhpd2igq9484dbsh81sf08k2kl"))
-       (modules '((guix build utils)))
-       (snippet `(begin
-                   ;; Remove bundled libffi
-                   (delete-file-recursively "ext/fiddle/libffi-3.2.1")
-                   #t))))))
-
 (define-public ruby-2.3
   (package
     (inherit ruby)