summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-19 15:01:13 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:59 -0400
commite8dc6ec5d8084efef4341ef90ec5e66ce31c1f03 (patch)
tree9244235b122e7c3dc62b79d5149a89cd65fecc38 /gnu
parent8f3eb93cb0d2e1c506995050496e32e30911dd34 (diff)
downloadguix-e8dc6ec5d8084efef4341ef90ec5e66ce31c1f03.tar.gz
gnu: python-amqp: Update to 5.1.1 and enable tests.
* gnu/packages/python-xyz.scm (python-amqp): Update to 5.1.1.
[arguments]: New field.
[native-inputs]: Add python-pytest.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 14 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 86365a04c2..4831cebaa0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15673,18 +15673,27 @@ and provides a uniform API regardless of which JSON implementation is used.")
 (define-public python-amqp
   (package
     (name "python-amqp")
-    (version "5.0.7")
+    (version "5.1.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "amqp" version))
        (sha256
-        (base32 "0p9alyinl24z699w4gpd8wvn90sm2il1p0gfwdhbpinksy7vfmyp"))))
+        (base32 "1qmmffiy48nady7is8529vxcyqbq88v5zgawqr3fk4q8rkz166rc"))))
     (build-system python-build-system)
     (arguments
-     `(#:tests? #f)) ; not compatible with pytest>=6 as of 5.0.7
-    (propagated-inputs
-     (list python-vine))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (invoke "pytest" "-vv"
+                        "-c" "/dev/null" ;take control over pytest options
+                        ;; Integration tests require network connectivity.
+                        "--ignore" "t/integration")))))))
+    (native-inputs (list python-pytest))
+    (propagated-inputs (list python-vine))
     (home-page "https://github.com/celery/py-amqp")
     (synopsis "Low-level AMQP client for Python (fork of amqplib)")
     (description