summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-13 22:48:10 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-13 22:48:53 +0100
commitfd4c7a098a508c1de7a8513c0f3d88d5a0df12e7 (patch)
tree636624ba96d379a00bb5c7f6b4c737d88c0990f1 /gnu
parent55a0a3c853dc9177afeb9d438f3e4bdc1a1379e7 (diff)
downloadguix-fd4c7a098a508c1de7a8513c0f3d88d5a0df12e7.tar.gz
gnu: Add python-velocyto.
* gnu/packages/bioinformatics.scm (python-velocyto): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index da0edcdf40..9b0a4314b9 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14209,3 +14209,34 @@ short read sequences, removes errors then produces high quality unique
 contigs.  It then uses paired read information, if available, to retrieve the
 repeated areas between contigs.")
     (license license:gpl2+)))
+
+(define-public python-velocyto
+  (package
+    (name "python-velocyto")
+    (version "0.17.17")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "velocyto" version))
+       (sha256
+        (base32
+         "0fgygyzqgrq32dv6a00biq1p1cwi6kbl5iqblxq1kklj6b2mzmhs"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-click" ,python-click)
+       ("python-cython" ,python-cython)
+       ("python-h5py" ,python-h5py)
+       ("python-loompy" ,python-loompy)
+       ("python-matplotlib" ,python-matplotlib)
+       ("python-numba" ,python-numba)
+       ("python-numpy" ,python-numpy)
+       ("python-pandas" ,python-pandas)
+       ("python-pysam" ,python-pysam)
+       ("python-scikit-learn" ,python-scikit-learn)
+       ("python-scipy" ,python-scipy)))
+    (home-page "https://github.com/velocyto-team/velocyto.py")
+    (synopsis "RNA velocity analysis for single cell RNA-seq data")
+    (description
+     "Velocyto is a library for the analysis of RNA velocity.  Velocyto
+includes a command line tool and an analysis pipeline.")
+    (license license:bsd-2)))