summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-20 11:59:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-20 12:19:55 +0100
commit19a0a060d2d9540d0f151821227ba8b2fbbd2ef1 (patch)
treebbe2857a6e55cd0b0ada09349fcc8ca0f1e6c944 /gnu
parent35f9c6628fd52adca03d08e503d65fa68c573a8e (diff)
downloadguix-19a0a060d2d9540d0f151821227ba8b2fbbd2ef1.tar.gz
gnu: 389-ds-base: Fix tool references.
* gnu/packages/openldap.scm (389-ds-base)[arguments]: Rename phase
"fix-includes" to "fix-references" and fix references to certutil and
c_rehash.
[inputs]: Add nss:bin.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/openldap.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index 878dc0b4b1..6426c3067e 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -230,10 +230,15 @@ servers from Python programs.")
              "--disable-perl")
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'fix-includes
+         (add-after 'unpack 'fix-references
            (lambda _
              (substitute* "include/ldaputil/certmap.h"
                (("nss3/cert.h") "nss/cert.h"))
+             (substitute* "src/lib389/lib389/nss_ssl.py"
+               (("'/usr/bin/certutil'")
+                (string-append "'" (which "certutil") "'"))
+               (("'/usr/bin/c_rehash'")
+                (string-append "'" (which "perl") "', '" (which "c_rehash") "'")))
              #t))
          (add-after 'unpack 'fix-install-location-of-python-tools
            (lambda* (#:key inputs outputs #:allow-other-keys)
@@ -305,6 +310,7 @@ servers from Python programs.")
        ("net-snmp" ,net-snmp)
        ("nspr" ,nspr)
        ("nss" ,nss)
+       ("nss:bin" ,nss "bin") ; for certutil
        ("openldap" ,openldap)
        ("openssl" ,openssl)             ; #included by net-snmp
        ("pcre" ,pcre)