summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-18 16:26:18 +0200
committerMarius Bakke <marius@gnu.org>2022-09-18 16:26:18 +0200
commit2266ec5eb1bcc2c87baa27297a4205eebf325424 (patch)
tree60ae7bd1de3fbcbcd32c6f22a3f1611f234f3523 /gnu
parent51482db4da0104928d4f95fcce808687dc9b0334 (diff)
downloadguix-2266ec5eb1bcc2c87baa27297a4205eebf325424.tar.gz
gnu: python-cython: Remove duplicate version.
* gnu/packages/python-xyz.scm (python-cython-0.29.32): Remove variable.
* gnu/packages/python-science.scm (python-pandas)[native-inputs]: Change from
PYTHON-CYTHON-0.29.32 to PYTHON-CYTHON.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-science.scm2
-rw-r--r--gnu/packages/python-xyz.scm12
2 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index d828399f79..80acb606b2 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -422,7 +422,7 @@ library.")
     (inputs
      (list which xclip xsel))
     (native-inputs
-     (list python-cython-0.29.32
+     (list python-cython
            python-beautifulsoup4
            python-lxml
            python-html5lib
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 946b7e839b..56a07564c9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5605,18 +5605,6 @@ programming language and the extended Cython programming language.  It makes
 writing C extensions for Python as easy as Python itself.")
     (license license:asl2.0)))
 
-;; Newer version required for Pandas.
-(define-public python-cython-0.29.32
-  (package
-    (inherit python-cython)
-    (version "0.29.32")
-    (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "Cython" version))
-              (sha256
-               (base32
-                "1xqsihpqnfal29nb5kmw8z71nd4jbsnbz7p3lkr094xpb13wycw7"))))))
-
 (define-public python-cython-3
   (package
     (inherit python-cython)