summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-09 21:57:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:33:16 +0200
commit31342529b25a1b66f3c21084d4eb994b1c1cb478 (patch)
tree34b484a9a9c833d9f67b8daafb1318c582bafe80 /gnu
parent1bb191fc4b8fcb1fd444a93bc3db291d93f14969 (diff)
downloadguix-31342529b25a1b66f3c21084d4eb994b1c1cb478.tar.gz
gnu: Add java-eclipse-core-commands.
* gnu/packages/java.scm (java-eclipse-core-commands): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 15787529ec..95ddc581e2 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2800,6 +2800,31 @@ module @code{org.eclipse.compare.core}.")
 @code{org.eclipse.team.core}.")
     (license license:epl1.0)))
 
+(define-public java-eclipse-core-commands
+  (package
+    (name "java-eclipse-core-commands")
+    (version "3.8.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://repo1.maven.org/maven2/"
+                                  "org/eclipse/platform/org.eclipse.core.commands/"
+                                  version "/org.eclipse.core.commands-"
+                                  version "-sources.jar"))
+              (sha256
+               (base32
+                "0yjn482qndcfrsq3jd6vnhcylp16420f5aqkrwr8spsprjigjcr9"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:tests? #f ; no tests included
+       #:jar-name "eclipse-core-commands.jar"))
+    (inputs
+     `(("java-eclipse-equinox-common" ,java-eclipse-equinox-common)))
+    (home-page "https://www.eclipse.org/platform")
+    (synopsis "Eclipse core commands")
+    (description "This package provides Eclipse core commands in the module
+@code{org.eclipse.core.commands}.")
+    (license license:epl1.0)))
+
 (define-public java-commons-cli
   (package
     (name "java-commons-cli")