summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-09 21:43:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-02-09 21:58:18 +0200
commit3584cff93d5fd78faf9e41db629351bf570a63f5 (patch)
treec26577af5b4644a4b624455fb61451381febe753 /gnu
parent66a6c516e2b774805c2c583766d8231f6b58e028 (diff)
downloadguix-3584cff93d5fd78faf9e41db629351bf570a63f5.tar.gz
gnu: go-github-com-spf13-pflag: Fix building with newer go.
* gnu/packages/golang.scm (go-github-com-spf13-pflag)[source]: Add
snippet to fix test suite with newer versions of go.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1f89ce0609..22f6ec5e8c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
 ;;; Copyright © 2016 Andy Wingo <wingo@igalia.com>
 ;;; Copyright © 2016, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
@@ -4134,7 +4134,16 @@ applications as well as a program to generate applications and command files.")
         (file-name (git-file-name name version))
         (sha256
          (base32
-          "0gpmacngd0gpslnbkzi263f5ishigzgh6pbdv9hp092rnjl4nd31"))))
+          "0gpmacngd0gpslnbkzi263f5ishigzgh6pbdv9hp092rnjl4nd31"))
+        (snippet
+         #~(begin
+             (use-modules (guix build utils))
+             ;; Fix compatibility with go-1.19+
+             ;; https://github.com/spf13/pflag/issues/368
+             (substitute* "flag_test.go"
+               (("fmt\\.Println") "fmt.Print")
+               (("\\+ got\\)") "+ got + \"\\n\")")
+               (("\\+ defaultOutput\\)") "+ defaultOutput + \"\\n\")"))))))
     (build-system go-build-system)
     (arguments
       '(#:import-path "github.com/spf13/pflag"))