summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-05 22:27:56 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-05 23:40:23 +0100
commit39aadc7171a876fec9ce9c42aca3c2d9776d4d63 (patch)
treefe792f240556ed1f5e18fe25282dff5da3efcdc2 /gnu
parent5f1c60134d2f153d1bc3fa87e339f45dc1ec0c8f (diff)
downloadguix-39aadc7171a876fec9ce9c42aca3c2d9776d4d63.tar.gz
gnu: rust-alloc-no-stdlib-2.0: Remove variable.
* gnu/packages/crates-io.scm (rust-alloc-no-stdlib-2.0): Remove variable.
(rust-alloc-stdlib-0.2):
(rust-brotli-decompressor-2): Use rust-alloc-no-stdlib-2 instead of the above.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index bfb7be10a3..4d0aca50c3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1368,8 +1368,6 @@ stack, or by a package that wishes to simply use Box<>.  It also provides
 options to use calloc or a mutable global variable for pre-zeroed memory.")
     (license license:bsd-3)))
 
-(define-public rust-alloc-no-stdlib-2.0 rust-alloc-no-stdlib-2)
-
 (define-public rust-alloc-stdlib-0.2
   (package
     (name "rust-alloc-stdlib")
@@ -1385,7 +1383,7 @@ options to use calloc or a mutable global variable for pre-zeroed memory.")
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
-       (("rust-alloc-no-stdlib" ,rust-alloc-no-stdlib-2.0))))
+       (("rust-alloc-no-stdlib" ,rust-alloc-no-stdlib-2))))
     (home-page "https://github.com/dropbox/rust-alloc-no-stdlib")
     (synopsis "A dynamic allocator example that may be used with the stdlib")
     (description "This package provides a dynamic allocator example that may
@@ -4477,7 +4475,7 @@ devices and kernels.")
     (arguments
      `(#:tests? #f      ; not all test files included
        #:cargo-inputs
-       (("rust-alloc-no-stdlib" ,rust-alloc-no-stdlib-2.0)
+       (("rust-alloc-no-stdlib" ,rust-alloc-no-stdlib-2)
         ("rust-alloc-stdlib" ,rust-alloc-stdlib-0.2))))
     (home-page "https://github.com/dropbox/rust-brotli-decompressor")
     (synopsis "Brotli decompressor")